2021年1月1日金曜日

Tenforflow 2.4.0 + cuda toolkit v11.0 on Ubuntu 18.04

 

  Ubuntu Circle of Friends 



今更ながら、自宅のUbuntu 18.04 マシン + NVIDIA Graphic board で、さくっと Tensorflow お勉強を試みるべく環境整備中に、CUDA Toolkit のバージョンでハマった。似たような問題と対策のページが Web上で簡単に見当たらなかったので、ひとまず記載しておく。

2021年1月1日現在、Ubuntu 18.04 上で、Tensorflow 2 (2.4.0) を動作させるには、CUDA Toolkit は、Version 11.0 が必要なようだ。CUDA Toolkit の他 Version では、Python3 上で「 libcusolver.so.10 がない」といったエラーが出る。

pip で Tensorflow をインストールした場合には、cuda toolkitのバージョンに注意が必要だった。で、間違ってインストールしてしまった場合の対処方法と合わせて備忘録として記載しておく。


cuda toolkit の削除:


sudo apt-get --purge remove nvidia-*
sudo apt autoremove
sudo dpkg --list
sudo dpkg --purge cuda-toolkit-11-2
sudo dpkg --purge cuda-toolkit-11-1
sudo dpkg --purge cuda-toolkit-10-2

(上記は、cuda-toolkit-11-2/11-1/10-2 の repository を既に追加していたので・・・実施した)




cuda toolkit 11.0 のインストール
(Tensorflow 2.4.0対応)



下記操作は、NVIDIAのページとほぼ同じ。最後だけ、Versionを追加(赤字)
https://developer.nvidia.com/cuda-11.0-download-archive?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1804&target_type=deblocal

wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/cuda-ubuntu1804.pin
sudo mv cuda-ubuntu1804.pin /etc/apt/preferences.d/cuda-repository-pin-600
wget http://developer.download.nvidia.com/compute/cuda/11.0.2/local_installers/cuda-repo-ubuntu1804-11-0-local_11.0.2-450.51.05-1_amd64.deb
sudo dpkg -i cuda-repo-ubuntu1804-11-0-local_11.0.2-450.51.05-1_amd64.deb
sudo apt-key add /var/cuda-repo-ubuntu1804-11-0-local/7fa2af80.pub

sudo apt-get -y install cuda-11-0



おまけ


Python3 上で、画像を表示する際に、以下のエラーで表示されないことがあった。その時の対策も記載しておく。


エラー

<stdin>:1: UserWarning: Matplotlib is currently using agg, which is a non-GUI backend, so cannot show the figure.


対策:

sudo apt install python3-tk




0 件のコメント:

コメントを投稿